Vs 2012

Cuervo

New member
Alright, I finally got around to doing this... migrating my recordedTV processing application from my old BTV server to MCE7 and the HDHR Prime. I was using VRD3 at the time and everything worked great, the recording would end, vrd would QSF the file to a new location, comskip runs, vrd cuts, season/episode data would be pulled from thetvdb and finally the file would be reencoded to MP4 and renamed for XBMC.

It had a couple of limitations in that it could only process linearly, meaning it could only process one file at a time, so if file A were in the encoding process, file B would have to wait to be QSRed. I unlinked that in my new shiny Win7 version so the individual steps could happen in parallel, but the files would still queue up when they were at the same step. Anyway, I was very happy with that since I'm not a programmer by any stretch. So, I finally go to add in the new VRD code, and I'm having problems.

I ran tlbimp on the videoredo.tlb that came with VRD and generated a .Net35 and .Net4 dll. For some reason the .Net4 dll didn't work so I changed to run my project trget to .Net35, which gets a bit further but still errors out in the variable declaration.
Code:
        Dim vrdSilent = New VideoReDo35.VideoReDoSilent
        Dim vrd = vrdSilent.VRDInterface
VRD does launch, and it appears in the taskmanager, but the next line throws an error and I'm hard pressed to figure out what it means and how to fix it.

Here is the error:
Code:
Unable to cast COM object of type 'VideoReDo35.VideoReDoSilentClass'
 to interface type 'VideoReDo35.IVideoReDoSilent'. This operation failed 
because the QueryInterface call on the COM component for the interface 
with IID '{3371A5A9-B029-4824-8BDF-0F62DF3CDF44}' failed due to the 
following error: No such interface supported (Exception from HRESULT: 0x
80004002 (E_NOINTERFACE)).
Any insight into this would be appreciated.
 
Last edited:

sofakng

New member
Are you running 64-bit?

If so, try running regtlibv12.exe (inside \Windows\Microsoft.Net\Framework64\v4...) on the VideoReDo.tlb file. That solved my problems.

Let me know if it doesn't work.
 
Top Bottom