• On Septemer 25, 2018, the VideoReDo message board was moved to the Xenforo forum software. During the migration, we pruned thousands of inactive and spam users, if your user name was accidently removed simply register it again. Report any issues via email to support@videoredo.com.

VideoReDo crashed

#1
Hi,
Application crashes when you click Cut Selection (or Trim Unselected (or similar functions in the menu) from a certain time... (BEX event type). Reinstalling the program does not help,,,,
The same application running as an administrator is functioning normally without any problems.

App: VideoReDo TVSuite v.5.3.83.763 (same as last Beta v.5.3.83.771)
OS : Windows 10 Pro 64bit 1809/17763.55 (1809/17763.134 now)

Attaching Report.wer, AppCrash.evtx, and VideoReDo.log files as archive file VRDcrash.zip.
 

Attachments

#3
@Danr OK, I'm sending… BEX is terminus technicus in Windows, I think. Something like a stack overflow.

Something is wrong !
A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:
support@videoredo.com


It's okay now, the SMTP server did not like the ZIP archive :)
 
Last edited:

Dan203

Senior Developer
Staff member
#4
Try this just as a test...

Uninstall
Reboot
Disable antivirus
Reinstall
With antivirus still disabled try again

If that works add an exception for the VideoReDo install folder to your AV program before reenabling.
 

Dan203

Senior Developer
Staff member
#6
When you say running as administrator doesn't have the issue. Do you mean running it under a different account that is an administrator? Or do you mean right clicking and selecting "run as administrator"?
 
#7
In both cases, both when working under the administrator account and as well as a normal user account with the option run as administrator. The problem is only and only in my user profile and shows itself only when a single specific action (Cut Selection button). All other events (play, stream fix, moving, etc ...) of an application without a problem.

What makes the application just click the Cut Selection? What function calls in this step?
Ladislav Jansa
retiree
 

Dan203

Senior Developer
Staff member
#8
Nothing really. It adds the cut to the list, updates the undo list and updates the cut list box on the right. All of the code is pretty much standard MFC code and controls. Nothing fancy at all that would require admin privileges.

One thing... are you replacing a cut that would trigger the prompt to replace an existing cut? Or just adding a cut in an empty green area? Replacing a cut does use a 3rd party lib to display the special dialog used, so I guess that could potentially cause an issue on a non-admin system. Although we've never seen any other reports of this. Other than that the code basically creates an object indicating the start/end of the cut, adds it to an internal array, and then updates the list box to display the newly modified array. No pointers are used or any non-standard code that would even trigger a crash.
 
#10
1. Run the application
2. Select and open the video
3. Click Cut Selection (or Trim unselect, or Delete selection in Menu, etc...)
4. The application quits (same as Menu / File / Exit )

More specifically, when I click on the button the selected area should change color from green to red. Instead, the application generates the wer file and exits.
Up to the moment, when I click on any of the buttons, I can normally work in the application: start the Stream Fix, move the start or end of the cut, play video, etc…

I'm not a programmer and I was not, I use the Czech language version of Windows. Of course I tested the app with both languages. When you run Setup and select the language I have always kept the default language of the OS, i.e. the Czech language. Now I have uninstalled and installed again for the last time with the initial choice of language English. Application's behavior does not change, the problem still remains.

On Thursday 8. November, I tested the functionality of the Office365 beside Office2003 and coincidentally there was a global failure of the license servers in the Microsoft. Subsequent error messages Windows (Windows is not activated) I mistakenly attributed to his intervention in the OS and I performed a system restore to an earlier restore point that I created just before testing. I assume that the problem in the VRD was this time, but I can't rule out another influence ...
 
Last edited:

Dan203

Senior Developer
Staff member
#11
When you uninstall/reinstall are you restoring your settings from a file? Or just going with the defaults?

I can't reproduce your crash, nor can I see anything in the code that would cause a crash when pressing one of those buttons. As I said above those buttons don't do much. They create an item containing the start/end of the cut and add it to an array. Everything else it does, like updating the UI, is done in a bunch of other places too so if that were the cause you'd have run into it elsewhere.

Unfortunately it could be that the restore you did corrupted something in Windows that is affecting VideoReDo.

Just as a test can you try one more thing.... create a new non-admin user on your PC. Switch to that user account and install VideoReDo. Does it have the same issue? Or does this only affect your original user account?
 
#12
I am an older man and I do not share the philosophy of the owners of Microsoft, the personal computer is used for playing video games, and music and video playback.

I resisted for a long time to use the user profile under your Microsoft account, but I wasn't consistent and I'm losing them. Very, I fear that in the mutual links between different types of profiles, not even the boys of Redmond. Simulate I earlier profiles (local), and installed the VRD. The result is a condition when the very same problem manifests itself even under the admin account.
From the beginning it was obvious that the problem is something wrong in my user profile. My computer is now in a state that does not meet stringent standards of far from MS Windows operating systems configuration (ironic).
On my computer the problem was reproducible at any time despite variable reinstallation of the application. In the current state of the OS is another search for the causes of the issue irrelevant.
I performed a clean installation on nearly new laptop (Dell, same OS, better HW). Installation and functionality, without issue. I am preparing mentally to a possible reinstal the OS... :cry:

The attempt to create another user profile was successful this time. The previous attempt failed for conflicts between the Microsoft account and local accounts.
I successfully installed the application under the new account (again without requiring a license key), the new account does not experience the problem, the application is operational. In both original profiles the problem lasts.

The attempt to create another user profile was successful this time. I successfully installed the application under the new account (again without requiring a license key), the new account does not experience the problem, the application is operational. In both original profiles the problem lasts.

The biggest problem with the application is probably the inability to thoroughly uninstall. Due to the strange philosophy of Microsoft, similar problems will be reconsidered. I thank the administrator of the forum Danr and above all developers of application Dan Haddix (Dan203) for willingness and patience.
 

Dan203

Senior Developer
Staff member
#13
OK so there are a few things left behind when you uninstall. First of all there are some XML files left in the Documents/VideoReDo folder. This is where you custom profiles, UI Styles and DVD templates will be stored. There is also a folder under users/<YourName>/AppData/Roaming/VideoReDo where we store things like the log files, batch jobs, and some other temp files. You should try deleting those both when you uninstall. All the settings in the registry should be wiped out, but it's possible because of the restore those aren't or something corrupt is being left behind. Have you ever used RegEdit? If so launch it and go to HKEY_CURRENT_USER\Software\DRD Systems\VideoReDoPro and see if anything is left behind. If there is delete it.

The only other thing left behind is license related and are intentionally hidden and impossible to delete. (to prevent multiple trials being used)
 
#14
Immediately at the first occurrence of the problem described, I decided that it is probably a mistake only my profile and I tried to remove all the remains of the application from the system.
I unsuccessful retries and searches, I gradually discovered and deleted all the stores of both profiles on my computer (user and Admin). During a new installation, some of the original settings have always appeared.
HKEY_CURRENT_USER\Software\DRD registry key Systems\VideoReDoPro I didn't see. So now I have tried to import this key from the new functional profile into the original profile. Again without the desired response.
When you tried to create a new profile, you were always experiencing problems related to profile types (local or Microsoft, user, or admin) and accompanied by a constant forced Microsoft account,
I gradually discovered these location fragments of the application. Their editing/deletion did not lead to the result:

- C:\Program Files (x86)\VideoReDoTVSuite5\ ... all users
- C:\ProgramData\Microsoft\Windows\WER\ … global error messages
- C:\Users\UserName\AppData\Roaming\VideoReDoTVSuite5\ … user UserName logs
- C:\Users\UserName\Documents\VideoReDo\ … some user UserName settings
- HKEY_CURRENT_USER\Software\DRD Systems\VideoReDoPro … user UserName Reg DB key

Very much is preventing the new installation of OS, possibly the necessary configuration of the new profile. I would welcome any additional tips...

No more user manuals are not what they used to be, but the collection of infantile graphics and advertisements... so is probably only read by few :)
 

Dan203

Senior Developer
Staff member
#15
If you deleted all that and it didn't fix the issue then I can't think of what else would cause it to only crash in your profile and not others. You found all the locations where we store program specific settings and files. The only other thing left would be something to do with the license, but as I said I can't really help with that as it's intentionally randomized for ever machine to prevent hacking/theft. I have no way to even know where it's storing data on your system. Plus it's unlikely that the license system would cause a crash when you attempt to make a cut anyway. It's not referenced in any way in that function call, or any related calls.
 
#16
Thank you again for trying to help, the bug isn't in the application but in my user profile. I didn't discover the cause of the trouble, but I just bypassed the issue by creating a new user profile... I'm running VRD as another user (runas) from my corrupted profile. VRD works reliably again.

P.S. I'm looking forward to editing HEVC ...
 

Dan203

Senior Developer
Staff member
#17
I wish I could help you figure out what is corrupting your profile, but it could be any number of things. Since you already tried deleting the registry entries and the user folder the only other thing I can think of is a corrupt DLL somewhere. Unfortunately hunting down something like that is nearly impossible.
 
Top