Videoredo and DVD lab pro

megageek2000

New member
Anole said:
I'm quite comfortable running the beta versions, and 459 is the current English ver available.
See the release notes, for some good reading.
1. I dowloaded the 459 beta and ran QSF on the already cut file as my original is gone.
2. Now I demux the QSFed file to mpv and mpa in VRD and load in DLP.
3. No TMPG or chaptering, I just did a compile and still same problem.

Anole said:
We need to get this fixed, if it takes you sending me the raw!
I missed that race, so I have a vested interest! ;)
I am willing to upload the file if you can tell me where, it is 2.19GB, or I can put it in a DVD and mail it. Let me know.

Thanks for all your help.
 

Anole

Moderator
We should see about getting you some help from the developers @ VideoReDo, too.

But in the meanwhile, if you want to mail me the raw data, I'll take a look.
I'd offer to let you FTP xfer it to me, but it'd take a while.
I'll give you an account and password (via personal message) to my FTP server , if you like.
I should be able to handle any reasonable upload speed you can muster: over 340 kiloBytes/sec

Yes, the Inside GP is trimmed a bit at the beginning but I put it in 'cause it fit. :)
I don't normally include the practice unless it is something notable like last years run at Indy!
And my reason for making this show, is for a friend who's satellite-impared. ;)
I like to watch, but wouldln't otherwise collect 'em.
 
Last edited:

Anole

Moderator
Okay, after two days leisurely file transfer, I have the 2.2gb .mpg file causing problems.
First , I had VideoReDo demux it to .mpa and .mpv files.
Then, I ran it through DVD Labs Pro 1.5-something.
It did give up maybe 1/4 the way into muxing the file, after other machinations.
I have recreated your problem.

Was a little disappointed to learn that this is post-edit and post-QSF.
But, I understand the original is gone. :(
What would be good for next time, is to use the latest VRD and QSF the file with that.
Take note of the error list at the end of the QSF run.
Then, forward the log file to the VRD team to figure out where and what was going wrong.
Once you've done the QSF, the info is lost from the output file.
If we could isolate where the glitches are, Dan and the boys could take a look at them and we mightl learn more.

I'm guessing you either had interference in your signal, or there was signal loss from the remote race site to Dish hq.
My experience of race #2 had remote drop outs, and some serious bitching by VRD, but DVDlabsPro processed the files just fine.

At this point, it should be pointed out that there are three DVD Labs:
1) old ver 1.3 is the last of the original line and no longer supported
(there was a 1.0 Pro, but it was pretty buggy)
2) Studio is a low-end version made from the Pro 1.5 source
3) Pro ver 1.5 is based on a new video library, different from old 1.3

The muxer in Pro 1.5 is somewhat forgiving and has been digesting my Dish video pretty well.
Old version DVD Labs standard ver 1.3 had two muxers.
There was the main/fast muxer, and then they had a relaxed version.
My Dish files never would go through the main muxer - I always used the relaxed version, and learned how to get the job done.
I've just crammed your two hour race through old DVD Labs,.
It ran to completion.
I've burned a DVD, and we'll see how it worked.

film at 11 ... ;)
 

megageek2000

New member
Thanks Anole, for the VRD/QSF tip - will keep this is mind for the future.

Spent some time over the weekend trying to put an end to this problem/irritation/frustration.

Firstly, I dumped the VRD processed file into DLP and at the point when DLP stopped, I looked at the size of the data processed in VIDEO_TS. That gave me an idea of what percent processed in comparsion to the original MPEG file.

Now, I cut the file to that point in VRD and again a further cut down the line. This way I had isolated the problem segment. Now, I processed the small problem segment through TMPGENC setting the Video Size to 544x480 2 pass VBR and Audio to 160 MP2. I also set the file size in the last step of the Project Wizard to match the original hoping to keep the bitrate as close to the original. Then, I joined the files back in VRD and DLP processed it fine.

The one thing I noticed was that the Audio in the file was switching between MP2 and LPCM audio, this will cause a Runtime error in DLP at the switch point, not a compile error. The reason could be that I have my DVR set to Dolby/PCM to support 5.1 from HBO/Max. Now, I have them all set to PCM which was my original setting and that should elimiate the Runtime problem. TMPG on the smaller segments is my solution to the compile problem for now and I have all the DVD's that were pending. TMPG is slow and there is no need to recode the entire file.

Also the problem with DLP version 1.3 is that the chaptering does not work and I dont think it supports multiple VTS. I had success using relaxed Muxer in 1.3 too, but I like the 1.53 features more and templates for my Tennis/F1/Soccer DVD's.

The other option for some people who may be interested is to add like a blank video glitch for about 30 sec at 544x480 and merge it at the beginning of the video. Then run DVD Patcher and patch the first header to 720x480 with 8MBps (DVB is 544x480 & 15MBps). Then in any standard DVD authoring software will not reencode your video and will leave it alone. Also, if you set the audio to MP2 and 160Kbps (to match the DVB audio format), it will not be transcoded.
 

Anole

Moderator
The disc made with DVDlabs 1.3 did not play.
There was some sort of error message when I told Nero to burn the thing, and I never got to the bottom of the problem.
But DVD Labs 1.3 did pass the file through the compiler without a bitch.

Watching the source video, I found a number of places where there were noticable errors.
They were in first quarter (?) of the file.
I'd considered looking closely at the bad spots, and one by one, re-cutting out that scene if at all possible.
Not an attractive proposition for a live-action show.

I also considered isolating one of the offending segments and forwarding it to the boys at VRD for their take on it.

I thought you'd basically run the latest QSF beta on the file, so it took a buddy to make me think maybe I should do that on this end.
Might find/fix something. Couldn't hurt, but I have yet to do it.

Lastly, and most painfully, I considered installing WinAVI (which I own) onto my big machine and converting the entire two hour show to full DVD resolution.
Now, the smart thing would be to lower the quality-setting to reduce output file size, but from experience, I doubt any actual quality would be lost.

In the middle of all this, on Monday my DSL connection burped, and I've lost my ICQ account.
Been a hard few days. ;)
 

Anole

Moderator
I have installed DVD Labs Pro 1.60 (an upgrade for 1.53), and it fails to compile the show, too.
Still looking at the other options mentioned above.
 
Last edited:

megageek2000

New member
Build 445 solved the problem 459 is better

Since my last post, I had lost the original MPEGs from the Dish, so this time after ripping the Nasdaq 100 tennis qf and sf match with PVR Explorer Pro, I ran it through build 445 anbd DLP processed fine, no hitch but it still complained about open GOPs. Then, I ran the original MPEG thru build 459 and it is better, no open GOP complaints and processed fine in DLP.

No need to QSF or to split into ES in VRD.
 

Anole

Moderator
great test !

And that is why I like to keep to the latest beta builds ...
...when they're working on anything related to my favorite subject:
.......strange satellite mpg. ;)

VRD just gets better each month.
Especially for us living on the crumbling edge. :)
 
Top Bottom