Video Thread: Video Dimensions changed


New member
I just transferred my first TiVo series 3 file to my computer.

I can play the file just fine (in VLC) but if I try to load it into either VideoReDo Plus or into TVSuite, I get the message "Video Thread: Video Dimensions changed".

I read that I should run QuickStream Fix first, so I tried that, but there were two problems: the resulting video looked terrible (in VLC) and I got the same error message from VideoReDo when I tried to open it.

I'm running the latest VideoReDo Plus (.512) and I'm running the beta of VRD TVSuite (.552)


Super Moderator
Make sure to use the filters option in QSF.

Process the file through QuickStream Fix first, then load the fixed file for editing. Tools>QuickStream Fix

Check Enable Filters in QuickStream Fix and select the resolution you desire to output. If multiple resolutions are not listed, increase the number of samples. Usually a number like 128 is sufficient.

Here is a guide to assist you


New member
I followed the guide as you mentioned. I checked "Enable Filters" and then set the number of samples to 128. I had only one resolution listed (1280x720). I then upped the number of samples to 500 and still had only this resolution listed. I then chose 5000 (and waited a bit) and still had only this 1280x720 resolution.

I re-ran the QSF (the file is a one-hour TV show which XP reports as taking up 5.5 GB). At the conclusion, I got this:

Audio frame errors: 5
Video resync frames removed: 107803
Video output frames: 107828
Audio output frames: 112433
Processing time (secs): 386
Processed frames/sec: 278.99
Actual Video Bitrate: 8.57 Mbps

Though the audio and video appear synced throughout, the video is very jerky, like it goes into slow-motion for a second, then it rapidly catches up. This continues over and over, and makes the video feel like it's pulsing.

Recall that I can watch the original file (in VLC) without any problems.

** UPDATE **

I ran it again through the QSF that comes with the trial version of TV Studio with markedly different results. This time, I got:

Audio frame errors: 5
Video resync frames removed: 1
Audio resync frames removed: 1
Video output frames: 215657
Audio output frames: 112434
Processing time (secs): 303
Processed frames/sec: 711.11
Actual Video Bitrate: 6.05 Mbps

...and the file is in excellent quality.

So, is the new QSF going to be updated in VideoReDo Plus? I'm a registered user of that one!

Last edited:

Raymond Day

New member
I get this too.

I reinstalled my windows XP pro too. So this is still close to a new install.

Start to edit and it can get so fare and error and have to start over and hope it can get though this time. But it don't do the error in the same place. Looks like this is only from TiVo videos from a HD TiVo.

I typed the error I got one time:

Video Thread: Video Dimensions changed.

You have unsaved edits.
Click ‘Yes’ to proceed and lose your edits.

Problem while seeking to:00:59:59.23

Please consider running Tools>QuickStream Fix
I even every 2 edits and saved it out then edit that. I got to 4 edits and now every time loading up the 4th one clicking on over a hour in the bar will get that error.

-Raymond Day


Staff member
Did you try running QSF with the filters enabled? Even if there was only one resolution you can try selecting that.

Raymond Day

New member
Yes I ran QSF

I did run "QuickStream Fix" It saved out a file and it just did the same error on that one.

At lest VideoReDo saved it out to mpg and I edit the rest of it with my old editor MPEG-VCR It's a fast editor too but only for mpg videos or vob ones. It don't have a nice geard down slider like VideoReDo dose.

I think this is a error with VideoReDo because I use the same save out file I did with VideoReDo and all way would get that error when I clicked past the 1 hour mark. But MPEG-VCR did not give any errors and saved it out very good.

Mybe VideoReDo could be faster if they did like MPEG-VCR does. It like shows the videos you editing with a lot of detal not showing so it's a little like a grid. You don't need nice video when editing.

-Raymond Day


QSF differences: Plus vs. TVS (?)

Yes, it will be updated sometime this month.
Obviously this hasn't happened yet, since the current version of plus is still 512.

I knew only the TVS version had the COM function for setting the filter dimensions but I was surprised to learn there are actual performance differences between the two QSF versions (discussed earlier in this thread).

Are all the performance differences related to multi-dimensioned videos?

Is the plus update still planned?


Thanks, still wondering: Are there performance differences other than those related to multi-dimensioned videos?


New member
What's going on with development on this?
I'm on version and cannot process half of my programs because of the changing video dimensions during commercials.
This is a killer for me.
Quickstream Fix is not solving the problem.

2009-10-20 08:49:31 Using display driver: VMR7
2009-10-20 08:49:31 VMR7 (Windowed), MEDIASUBTYPE_RGB24
2009-10-20 08:49:31 VMR7 (Windowed), MEDIASUBTYPE_RGB24
2009-10-20 08:50:13 Player - Video dimensions have changed from: (704 x 480) to (528 x 480).
2009-10-20 08:50:13 Video Thread: Video Dimensions changed.
Top Bottom