Saved h.264/MP4 file has wrong language information

danielkbx

New member
Hi,

I used to cut and convert my recordings (Mediaportal Backend, German SKY) to h.264 videos in MP4 containers. Now I noticed that all files have "English" as language for every audio stream in the file. I do not re-code the video nor the audio.
I tried to fix this with mp4v2's mp4track which is pretty neat and stable but it always aborts complaining about an error in the file.

So it looks like the generated MP4 files do have format errors and the language information is wrong. Anything I can do about it?

I checked the setting "ignore transport stream maps" but it is disabled (I read this in another thread).

Thank you,
danielkbx

Edit: I saved the same project as ts and mkv file and they seem to be right. So it might be a problem with the MP4 writer.
 
Last edited:

Dan203

Senior Developer
Staff member
I'm not able to reproduce this. I used a TS file with two audio tracks, "nar" and "eng", and saved to MP4 and the resulting MP4 retained the two languages.
 

danielkbx

New member
I tried to create a sample file. During this I noticed that every audio track is correctly saved when the movie is quite short.

I uploaded a sample.ts file to Dropbox: https://www.dropbox.com/s/41046n7ecsr7yon/Sample.ts?dl=0

When I open this file and save it as an H.264 mp4 file, both audio tracks have the same language id (though the track itself has the correct audio data) and mp4v2 cannot open the file.
 
Top Bottom