output stream error output byte unaligned

thjoca3

New member
I'm trying to take a mt2s file that I previously joined via vobmerge or the cli and the time of the video comes in at 8m26s, where the video is around 1h 46m total. I was hoping this program would be able to fix that and make the full video length available without having to convert to another format. I'm not sure if this is something that it can actually do or not, but was hoping so. When doing a quick stream fix, it starts and eventually I get the above error, but when I open the new video it does have a length of 12m36s, or if I just open the original and save the file, it will say "no cuts defined, do you wish to re-mux the entire input file?" if I click yes, it will start, and eventually I get the same error, but the output file ends up at 13m22s... so seems to be doing what I want untill the error.... I did try with the TV h264 version also, but would get a lot of buffer errors. Seems to be a lot of these errors in the logs


2018-10-24 16:58:40 TS->PTS Underflow in: Video Stream @ PTS: 57382.16 (00:00:57.08), Underflow: 2401.38 msec, Count: 90, Video BR: 28.316
2018-10-24 16:58:40 H.264, AC3 (Unpacked2) Audio Frame Error 84 at: 00:01:08.20, Maxretries: 32000
2018-10-24 16:58:40 H.264, Invalid AC3 frame at PTS: 0.00 (00:00:00.00)
2018-10-24 16:58:40 H.264, Invalid AC3 frame at PTS: 69334.18 (00:01:09.07)
2018-10-24 16:58:40 TS->PTS Underflow in: Video Stream @ PTS: 57799.23 (00:00:57.18), Underflow: 2628.83 msec, Count: 100, Video BR: 28.316
2018-10-24 16:58:40 H.264, Invalid AC3 frame at PTS: 0.00 (00:00:00.00)
2018-10-24 16:58:40 H.264, AC3 (Unpacked2) Audio Frame Error 85 at: 00:01:09.11, Maxretries: 32000
2018-10-24 16:58:40 H.264, Invalid AC3 frame at PTS: 0.00 (00:00:00.00)
2018-10-24 16:58:40 H.264, Invalid AC3 frame at PTS: 0.00 (00:00:00.00)
2018-10-24 16:58:40 H.264, Invalid AC3 frame at PTS: 0.00 (00:00:00.00)
2018-10-24 16:58:40 H.264, Invalid AC3 frame at PTS: 0.00 (00:00:00.00)
2018-10-24 16:58:40 TS->PTS Underflow in: Audio-0 @ PTS: 62824.00 (00:01:02.19), Underflow: 220.32 msec, Count: 1, Video BR: 30.679
2018-10-24 16:58:40 H.264, AC3 (Unpacked2) Audio Frame Error 86 at: 00:01:11.16, Maxretries: 32000
2018-10-24 16:58:40 TS->PTS Underflow in: Audio-0 @ PTS: 62856.00 (00:01:02.20), Underflow: 258.66 msec, Count: 2, Video BR: 30.679
2018-10-24 16:58:40 TS->PTS Underflow in: Audio-0 @ PTS: 62888.00 (00:01:02.20), Underflow: 285.96 msec, Count: 3, Video BR: 30.679

Any suggestions?
 

Dan203

Senior Developer
Staff member
You can fix the underflow error by increasing the mux rate. Set the mode to manual and set the muxrate to 50000. No guarantee it wont have other errors if the join was done incorrectly
 
Top Bottom