Mpeg stream error: open error for wtv output

Formation4

New member
Hi Dan

Tried that still says same output error. Is there a way i can save it as mts file and have that played in wmp. Just tried that but no audio in wmp. Is there a codec I need.
 

Dan203

Senior Developer
Staff member
Did you upgrade to Win8 or did you do a fresh install? If you upgraded can you try completely uninstalling and reinstalling VRD?

Dan
 

Formation4

New member
I removed vrd. Removed the file created. Then re-installed but still same output error. Had to kill the process in order to restart. Looking at converting them using MC TV. Trying to get audio on to the outputted file
 

Danr

Administrator
Staff member
Can you start VRD with elevated permissions (Run As) and see if that helps?
 

Formation4

New member
I have launched vrd with elevated commands and tried again. No luck. I tried saving a ts file as a wtv file and chose audio options as automatic, then mpeg 2 layer then aac and unticked multiple audio streams. All failed on saving a wtv file.

I am now using npvr and that is giving me ts files. However playing back original recording there is no audio on hd files. Regular sd transmissions have sound. Am I missing a codec. Files are being played back through wmp.

Now the funny thing is take the hd recorded ts file made by npvr and put in vrd press play and sound is there. I can then edit out stuff and save as a ts file and not a wtv. It's not the end of the world.

But does anybody now good links for audio codec for npvr for hd streams
 

Danr

Administrator
Staff member
Too bad elevated didn't work. I'll try here when I get power back. DanH hasn't had any issue himself so let's hope it something easy.

Two more things to try though:

1) When saving to .ts check the profile option (convert LATM to ADTS), or recode your audio to MPEG1 Layer 2.

2) Try doing the same with .wtv output. Maybe that will help.

.. Dan

Update: while you at it, if the above don't work, try recoding the video to MPEG2. Not a real solution, but i might give us some additional insights.
 
Last edited:

Formation4

New member
Hi Dan

where is this option (convert LATM to ADTS)

I have managed to get a wtv file outputted. I selected an original wtv file then edited random bits out and saved by unticking multiple audio streams and selecting mpeg2 layer 1 as sound. Choosing automatic failed and choosing aac failed
 

Danr

Administrator
Staff member
It's a checkbox in the lower right of the profile / Save options dialog.
 

Dan203

Senior Developer
Staff member
If you chose AAC then that means it was converted to ADTS. Sounds like this may be a problem with AAC audio. I don't think I tried any files with AAC in my tests. I'll try again on Monday and see if I can reproduce.

Dan
 

Dan203

Senior Developer
Staff member
OK I can confirm that this is an AAC issue. If you set the audio to any other format it seems to work fine. I don't yet have a build environment setup in Win8 so I don't know exactly what the problem is, but I'm working on setting one up now so I can fix this ASAP.

Dan
 

Dan203

Senior Developer
Staff member
If it's a file that you previously tried to process and it failed then check the output folder for a .tmp file with the same name. If there is one then it will cause this error too. Just delete it and try again.
 

Dan203

Senior Developer
Staff member
Check the output folder for .tmp files and if there are any delete them.
 

marvin-miller

New member
Found those and also found HD space was low. Another use posted that this could also cause the issue. It looks like it's case now thanks!
 
Top Bottom