Mpeg stream error: open error for wtv output

JMRDV

Member
644A - opened recorded tv shows - vrd stops at the multiple video dimension screen so i set to Quickstream and set to use batch manager. First show stops with that error - click ok and the 2nd starts and then fails as the 1st one did. When the output processing complete screen pops up it shows
actual video bit rate as -1.#J Mbps for both with zero frames in all the boxes. Processsing times were 338023 and 338183.

Also note that these two files both stalled when using VAP 1.08.

They are US tv shows - same series i have been recording and processing for awhile - never had these problems before.
 

Dan203

Senior Developer
Staff member
If you run the same files interactively through QSF with the dimension filter set does it work?

Dan
 

JMRDV

Member
No they both fail

I tried both shows - three ways
1st - let vrd pick the dimensions
2nd - picked 704 x 480 myself
3rd - picked 720 x 480 myself

both files failed individually. (not using batch manager)

VRD 4.20.646
 

JMRDV

Member
2 files uploaded

Dan,

I uploaded the two files to the JMRDV directory and sent email to your support address.

john
 

Dan203

Senior Developer
Staff member
Do me a favor check the output folder where you're saving the files. Are there any .tmp files? WTV does something a little strange. It writes out to a .tmp file first, then renames itself to .wtv when it's done. This is to work around an issue where MCE might try to process the file before it's finished outputting. However if there is a .tmp file with the same name already in the directory WTV output will fail with the error you listed because it will not automatically overwrite an existing file. If there are any .tmp files try deleting them and outputting the file again.

Dan
 

JMRDV

Member
No tmp files. Sorry for the late reply, in my NJ area, we just got power back last night and internet a few hours ago. I ran the files again to test.
 

Dan203

Senior Developer
Staff member
Hmmm.... There are two of you complaining about this, but I have Win8 installed on my machine and it works fine. I'm going to have to do some more testing and see if there is some particular sequence required to duplicate this problem.

Dan
 

JMRDV

Member
My video pc is windows 7 ultimate and this problem remains. I just uninstalled vrd, then reinstalled to a different drive altogether. Then put the files in question to a totally different folder and tried to process them - same failure.

My other pc now has windows 8 pro -> there is no problem whatsoever on that pc.

IF you want me to try anything let me know - I'll do my best when I have power which was about 1/2 the day today.
 

Dan203

Senior Developer
Staff member
Ok that's odd. The WTV output code hasn't changed in a while and I run Win7 x64 Ultimate myself and have no issues at all with WTV files. Is MCE installed? (not sure if it's an option or not in Ultimate) can you play WTV files in Windows Media Player? Can you open WTV files in VideoReDo?

Dan
 

JMRDV

Member
Yes to MCE installed, Yes I can play WTV in WMC and Yes they open in VRD.

Is there a way to make 100% sure that all remnants of prior VRD installations are removed from registry? If I knew the individual Keys I could even delete them manually to ensure that this is not the basis of the concern.
 

Dan203

Senior Developer
Staff member
If you do a complete uninstall and delete anything left behind in the install directory, then reboot your computer before reinstalling that should be enough.

Dan
 

Formation4

New member
I am also having this same problem. Worked fine on win 7 ultimate 64 bit. I now have win 8 pro with media centre.

Wtv opens and plays fine in videoredo.

Soon as i start to save to h264 wtv file format it comes back with mpeg stream error. Open error for WTV output.

Any way I can get this sorted. Please.
 

Dan203

Senior Developer
Staff member
I'm unable to reproduce this on my Win8 install. Can you please clear your log, then try saving a file again, and then send me you log to support @ videoredo.com. That might have more info as to where exactly it's failing.

Dan
 

Formation4

New member
I'm unable to reproduce this on my Win8 install. Can you please clear your log, then try saving a file again, and then send me you log to support @ videoredo.com. That might have more info as to where exactly it's failing.

Dan
Thanks
I am at work at the moment soon as I get in I will have a look. How do I clear log, save log in order to send over? Never had to send a log. I have been reading up on wtv files and vrd, the programme that was recorded was a hd channel, would that have anything to do with it
 

Dan203

Senior Developer
Staff member
There is a menu under the Help menu with all the log related options.

Dan
 

Formation4

New member
this is what i got after clearing log. running the wtv file again and getting the error

2012-11-09 18:32:08 Log file cleared, previous file renamed to: C:\Users\Mujibur\AppData\Roaming\VideoReDo-TVSuite4\VideoReDo (03).Log
2012-11-09 18:32:08 VideoReDo TVSuite started. Licensed to: MUMUJIBURRAH--, Version: 4.20.7.629 - Nov 15 2011, AVP On (00cf0062-1}
2012-11-09 18:32:46 WTV Reader - Found 0 skip chunks
2012-11-09 18:32:46 WTV Reader - Found 1 video streams and 2 audio streams
2012-11-09 18:32:46
***** Loading: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv

2012-11-09 18:32:46 H.264, Starting stream open for: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv
2012-11-09 18:32:46 WTV Reader - Found 0 skip chunks
2012-11-09 18:32:46 WTV Reader - Found 1 video streams and 2 audio streams
2012-11-09 18:32:46 H.264, Opening file: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv, filetype is: H264 PIDs: x233 / x232
2012-11-09 18:32:46 Graph monitoring thread started.
2012-11-09 18:32:46 Adding module to graph: H264 decoder
2012-11-09 18:32:46 Setting graph input port: 0 to module: H264 decoder port: 0 Accepts EOF
2012-11-09 18:32:46 H264 decoder: Starting video, H264 decoder thread.
2012-11-09 18:32:46 Graph monitoring thread started.
2012-11-09 18:32:46 Adding module to graph: H264 decoder
2012-11-09 18:32:46 Setting graph input port: 0 to module: H264 decoder port: 0 Accepts EOF
2012-11-09 18:32:46 H264 decoder: Starting video, H264 decoder thread.
2012-11-09 18:32:46 H.264, Starting stream open for: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv
2012-11-09 18:32:46 WTV Reader - Found 0 skip chunks
2012-11-09 18:32:46 WTV Reader - Found 1 video streams and 2 audio streams
2012-11-09 18:32:46 H.264, Opening file: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv, filetype is: H264 PIDs: x233 / x232
2012-11-09 18:32:46 H264 video, using display driver: VMR9
2012-11-09 18:32:46 VMR9 (Windowed), MEDIASUBTYPE_YV12
2012-11-09 18:32:46 VMR9 (Windowed), MEDIASUBTYPE_YV12
2012-11-09 18:32:48 H.264, Starting stream open for: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv
2012-11-09 18:32:48 WTV Reader - Found 0 skip chunks
2012-11-09 18:32:48 WTV Reader - Found 1 video streams and 2 audio streams
2012-11-09 18:32:48 H.264, Opening file: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv, filetype is: H264 PIDs: x233 / x232
2012-11-09 18:32:59 H.264, Starting stream open for: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv
2012-11-09 18:32:59 WTV Reader - Found 0 skip chunks
2012-11-09 18:32:59 WTV Reader - Found 1 video streams and 2 audio streams
2012-11-09 18:32:59 H.264, Opening file: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv, filetype is: H264 PIDs: x233 / x232
2012-11-09 18:32:59 Program Information
File: Name : G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv
Size : 0.378 GB
Duration : 00:08:07.02
Mux type : WTV
Video: Encoding : H.264
VideoStreamID : x233
Frame rate : 25.00 fps
Encoding size : 1920 x 1080
Aspect ratio : 16:9
Header bit rate : 20.000 Mbps
VBV buffer : 380 KBytes
Profile : High/4.0
Progressive : Progressive
Chroma : 4:2:0
Entropy mode : CABAC
Bit rate : 5.961 Mbps
Audio Stream: 1 (Primary) Codec : AAC
Format : LOAS/LATM
Channels : 2.0
Language : eng
PID : x232
PES Stream Id : xC0
Sampling rate : 48000
Audio Stream: 2 Codec : AAC
Format : LOAS/LATM
Channels : 1.0
Language : eng
PID : x234
PES Stream Id : xC0
Sampling rate : 48000
Subtitle: 1-1 Type : DVB Subpic
PID : 0x231
Language : eng
Page : 1

2012-11-09 18:33:34 H.264, Starting stream open for: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv
2012-11-09 18:33:34 WTV Reader - Found 0 skip chunks
2012-11-09 18:33:34 WTV Reader - Found 1 video streams and 2 audio streams
2012-11-09 18:33:34 H.264, Opening file: G:\Recorded TV\Fresh Meat_Channel 4_2012_10_16_21_58_00 2.wtv, filetype is: H264 PIDs: x233 / x232
2012-11-09 18:33:35 SyncWriter open returned: 80040207
2012-11-09 18:38:27 Image support lib: 6.1 build 137.56, ippvcp8l.lib+
2012-11-09 18:38:28 VideoReDo TVSuite started. Licensed to: MUMUJIBURRAH--, Version: 4.20.7.629 - Nov 15 2011, AVP On (00cf0062-1}
2012-11-09 18:38:28 Checking reg: 120
 

Dan203

Senior Developer
Staff member
I wonder if it's the second audio stream. When saving the file click the Options button in the Save dialog and uncheck the "Allow multiple audio streams" option. Does that help?

Dan
 
Top Bottom