LargeBufferMalloc No More Memory

glenpinn

Member
Hi guys, this "LargeBufferMalloc" No More Memory crash is starting to really annoy me.

I am in the process of tutoring my friend to finally use VRD for his video editing, and he has managed to get a bunch of his short 1080/50p MTS files edited ready to join up and add music tracks to, and tonight i was testing an output of my own to see what delay there might be from when the video starts and when the first music track starts (he wants a very short delay) and when i try it with a 19 minute 1080/50p mp4 file and I add a single or multiple music tracks just as a test, i get this error every single time.

i am able to use a 2 minute file and add one music track that is longer than the video without any problem.

Cheers
 
Last edited:

glenpinn

Member
EDIT: OK everyone, the BufferMalloc error seems to be apparent on my computer when VRD is reading the video and audio files from my working folder on my D-drive partition and also outputting the new file to the same partition or folder.

Unfortunately my editing pc is one of those Dell All in One computers like an iMac which has a 2tb hdd inside, and i have a 250gb partition for windows (C) and 1.6gb partition (D) for my storage, and for most of my video work i have no issues with importing and exporting my work to and from the D drive partition, however it seems that this BufferMalloc issue is stemming from me importing files from, and outputting the new files with audio back to my working folder in D drive.

I just moved my working files (the 14 minute 1080/50p elementary video and 6 minute audio track) into my C drive "Video" folder, i opened VRD to output the 1080/50p mp4 with the audio track and it has worked now by outputting the file to another project folder on the D drive partition, and i have tried this several times and it now does it without the BufferMalloc crash.

In the past when doing video editing i have always had a dedicated hdd or SSD for my windows and another hdd for my files, and i would put all my working files on the windows drive and output to the bigger files drive, but with only one hdd, i just dont bother doing this, i just let VRD read from, and output back to my D drive partition.

Now i have to start to learn putting my project files into the "Video" folder and output to the D partition to avoid this BufferMalloc issue when adding audio.

GRRRRRR ..... Seems VRD will not work when using an MP3 audio file to add to an elementary video, this is when i seem to get that BufferMalloc error more and VRD crashes, but everything is fine when i import an AAC or a WAV audio file.
 
Last edited:

SimonP

Member
I've just run into this 'LargeBufferMalloc:No More Memory' problem trying to run QSF on a 6GB .mkv file that is corrupted.

My buffer sizes are Min: 265 Max: 2048, I tried increasing Min: to 1024 but it was still the same.

Any suggestions?

(VRD 5.1.2.740)
 

Dan203

Senior Developer
Staff member
This usually happens when the file is corrupted to the point where we can't properly separate the audio and video. Or the file contains an audio/video for,at we don't support but is improperly recognized as one of the supported formats.

If your file is corrupt then that's the reason. QSF can't really fix corrupted files. It's main purpose it to fix files with bad muxing that causes seeking or sync issues. If the actual audio and video frames are corrupt then it can cause all sorts of problems.
 
Top Bottom