FFmpegsupport.dll not found

BWavin

Member
I have regularly saved mkv files with 619 but today it complains that ffmpegsupport.dll is not found. It is in the VRD folder but I have disabled use ffmpeg for mp4 in options so I am baffled!
Barry
 

Danr

Administrator
Staff member
Sounds like a bug. We are very quickly moving towards removing that option and using ffmpeg for all mp4 and mkv reading and writing.
 

Dan203

Senior Developer
Staff member
Perhaps your antivirus program is blocking it, or corrupted it in some way. Try reinstalling 619 with your AV software disabled then when you reenable your AV software go into it's options and add the VideoReDo install folder as an exception so it ignores all files in that directory.

Dan
 

BWavin

Member
Perhaps your antivirus program is blocking it, or corrupted it in some way. Try reinstalling 619 with your AV software disabled then when you reenable your AV software go into it's options and add the VideoReDo install folder as an exception so it ignores all files in that directory.

Dan
I uninstalled and reinstalled the prog which seems to have solved the problem..

I'm using MS Security Essentials adding the VRD folder to the exception list

Barry
 
Hello

I have never experienced above mentioned error until today. For the latest two recordings in row (10GB and 12GB TS 1080i AVC) I had attempted to cut and save (MKV, no-recoding) I got a complaint on missing FFmpegSupport.dll. The FFmpegSupport.dll is in place and not blocked by antivirus. VRD would not even start if it wasn't there. No useful info in LOG file either.

UPDATE: The error only occurs if NAS (windows share) is select as a target for output file. Saving edit to local HDD then manually copying output file onto the very same NAS share works normal. Now to even more interesting observation, while saving as .MKV fails, saving as .TS succeeds (both jobs with no-recode options). That's really suspicious behavior isn't it? Could eventually be a bug. The issue is reproducible every time.

UPDATE2: It seems like MKV muxer/exporter doesn't like long UNC paths. I decided to retry the save onto shorter path (still on the same NAS) and saving progressed. Still kind of bug or limitation plus the error message VRD shows could be revised as the current one is rather misleading.

VRD Version: 4.20.7.638 - Jun 18 2012
Code:
 1 Allow processing of improper AC3 PES packets      : True
 2 Allow DVRMS Output                                : False
 3 Allow Topfield Rec Output                         : False
 4 Allow Tivo Output                                 : False
 5 Allow VOB output file type                        : False
 6 Use Gold Splash Screen                            : False
 7 Only allow a single instance of VideoReDo         : False
 8 Resize fine-tune slider                           : False
 9 Append VideoReDo version to log filename          : False
10 Write Program Stream System Header                : True
11 Number of times a PMT has to be read when opening a file: 10
12 Skip conditional access transport streams         : False
13 Number of frames in the video buffer              : 128
14 Number of frames in the audio buffer              : 256
15 Maximum number of frames when doing a QuickStreamFix: 2048
16 Strip "User Data" blocks from Video Frames        : False
17 Remove duplicate SD NTSC closed captions          : False
18 Add GOP Timecode to all GOPs                      : False
19 Default AC3 Output Stream                         : 0
20 Output 'end of sequence' at end of saved file     : False
21 Restore missing 'progressive flags'               : False
22 Max Msec for audio sync adjustment                : 1000
23 Msec for seek completion before timeout           : 5000
24 Maximum volume adjustment range                   : 5
25 Enable right-click menu options                   : True
26 Total Size of DVRMS Writer Video Buffer           : 3000000
27 Number of MBytes before warning of restricted content: 3
28 Log TS muxer video bit rate                       : False
29 Do not copy BTV Meta Data                         : False
30 Use 'simple' not 'logical' file sort at open      : False
31 Write Thumbnail Audio Data to Log File            : False
32 Max frames for sequential Thumbnail search        : 30
33 Seconds before output warning triangle appears    : 60
34 Top lines to omit on frame capture                : 0
35 Display hundreths of seconds in timecode          : False
36 Winamp Plugin DLL                                 : 
37 User Batch Command                                : 
38 Application to display the log file               : notepad.exe
39 Create project files in XML                       : True
40 Enable closed captioning and subtitling           : True
41 Enable Fast MPEG2 Encoder                         : False
42 Enable multiple threads in fast MPEG2 Encoder     : True
43 Log fast MPEG2 Encoder actions                    : False
44 Always use NTSC DFTC format for 59.97 FPS         : False
45 Correct DVR-MS 25FPS NTSC files                   : True
46 Patch the DVR-MS header with the actual file duration: True
47 Minimum quant x 100                               : 250
48 Recode P-Frames quant percent                     : 120
49 Recode B-Frames quant percent                     : 120
50 Lower bit rate percent of target                  : 90
51 Minimum MPEG2 smart recoding bit rate (bps)       : 0
52 MBytes to pad when estimating DVD size            : 50
53 Keep closed captions (CC) when authoring          : True
54 Force silent DVD AC3 when audio bit rates don't match: False
55 Maximum DVD shrink percentage                     : 0
56 Customer Display Width                            : 720
57 Customer Display Height                           : 576
58 Double-click automatic zoom area seconds          : 0
59 Core I7, log audio buffer status                  : False
60 Use FFmpeg for MP4 files                          : True
61 Leave SPS/PPS in MP4/MKV H.264 frames             : True
62 Frames to check for variable frame rate           : 0
63 Remove H.264 embedded End Of Sequence NALs        : True
64 Enable output profiles                            : True
65 Disable H264 Mux sync adjustment                  : False
66 Use old batch manager                             : False
67 Enable support for multiple audio streams         : 1
68 Output AAC ES as M4A                              : True
69 Include initial B frames when first GOP is closed : False
70 Clear display frame buffers on save               : 1
71 MPEG2 display uses IPP decoder                    : True
72 IPP thread count (0=auto)                         : 0
73 Show tray icon in silent mode                     : True
74 Minimize batch manager to system tray             : True
75 Use new style file and folder dialogs             : True
76 Use windowed mode for VMR drivers                 : False
LOG
Code:
FFmpeg muxer - Error opening output file for MKV/MP4
For reference, an output path that doesn't work:
Code:
\\DISKSTATION\video\Dokument\LOH Londýn 2012\2012-08-12 Slavnostní ukončení.mkv
For reference, an output path that works:
Code:
\\DISKSTATION\video\2012-08-12 Slavnostní ukončení.mkv
Tomas
 
Last edited:

Danr

Administrator
Staff member
I can't duplicate it with my NAS (Netgear Ultra). Tried this output file in 638f:

Code:
\\nas02\temp\this is a really long long long long long long long long long long long long long long long long long long long long long long long long long long file name.mkv
I also tried your file name and it worked as well.
 
Sorry it's not NAS related after all. I have managed to nail the problem down a bit. MKV/MP4 exporter has issues with outputing file in folders having national character in name. Output pathname like J:\á\file.mkv will make MKV exporter to fail. Let's have a small walkthrough.

TS:
Request: Export to J:\á\á.ts
Result: Success, got J:\á\á.ts

MKV:
Request: Export to J:\á\á.mkv
Result: Fail, got message "Mpeg stream error:FFmpegSupport.dll library not found." and no output file.

Request: Export to J:\a\á.mkv
Result: Half success, got J:\a\�.mkv. File is ok, notice glitch in name.

MP4:
Request: Export to J:\á\á.mp4
Result: Fail, VRD application crashes in MSVCR100.dll and gets terminated.

Request: Export to J:\a\á.mp4
Result: Half success, got J:\a\�.mp4. File is ok, notice glitch in name

Such behavior is reproducible on my system, Windows7 x64 (Czech regional settings).

Tomas
 

Danr

Administrator
Staff member
DanH will have to check it out as he maintains the ffmpeg support. Might have to wait until we get the unicode file names implemented.
 

gerhard911

New member
I have just started getting this error on the latest VRD TV Suite 4.21.1.681. The FFmpegSupport.dll file is in the VideoReDo folder. I tried a reinstall to no avail so I uninstalled, rebooted and reinstalled. Still no go. The video file being processed can be saved on an older (much slower) computer so that should not be the problem. Possible Registry issue? I am XP SP3 with all MS maintenance applied. NO anti-virus on that computer (although there is on the older computer which can save the video).
 

gerhard911

New member
I did install and try V5 while waiting for a reply here. Same issue. I then remembered that when I tried saving the file with V4 on the old computer, I had saved it onto a local drive instead of my NAS. So I redid that test using the NAS as the save destination. That resulted in the same error.

Further investigation has revealed that my NAS file system has some corruption and cannot be written to. So it appears not to be a problem with VRD although the error message generated is quite misleading.
 

Danr

Administrator
Staff member
That is a misleading message. I'll open an internal issue to see if we can trap the error more gracefully and present a more meaningful error message.
 

Dan203

Senior Developer
Staff member
Not really a bug, just a bad error message. The muxer if failing to load because of the unicode characters in the file/folder name and it's throwing a generic exception. I should probably add a more informative error message for the exception.
 

Dan203

Senior Developer
Staff member
Actually it's fine. The exception is thrown only when the DLL fails to load. It doesn't even get to the point where it even attempts to open the output file when that exception is thrown. So unless your VRD install folder has unicode characters in the name I'm not sure how that could even be an issue. :confused:
 

Dan203

Senior Developer
Staff member
OK I found where the error was being misused. I changed it to use a more appropriate error instead. But we still can't support unicode so it's still going to fail if you save to a file/folder with unicode characters in the name.
 
Top Bottom