Error in COM script

pwantzel

New member
I'm trying to write a script using your COM routines. I get an error when I use this statement:
VideoReDo.SaveJoinerAsEx( args(1), 1 )

The error is: Cannot use parentheses when calling a Sub
Code: 800A0414
Source: Microsoft VBScript Compilation Error

When I use instead the statement:
VideoReDo.SaveJoinerAs( args(1) )
it works fine.

The same error occurs if I replace the 'args(1)' with the actual filename. This error also occurs when I run the sample program in the COM help section.

I'm running VRD TVSuite 547. Although, I notice that the statement (in your sample script)
Wscript.echo( VideoReDo.VersionNumber)
returns version 507 instead. I do have a number of older versions still installed (I've installed newer versions in different directories, not overwriting).
 

msmart

New member
I may not be able to help you directly, but 2 things come to mind. What version of TVS was last launched interactively? What version is in the default file path (C:\Program Files\VideoReDoTVSuite)?

I think I remember seeing in another thread that the COM routines use the version that was last launched interactively.
 

Danr

Administrator
Staff member
The syntax for VideoReDo.SaveJoinerAsEx( args(1), 1 ) is not correct. Give either one of the following a try:

call VideoReDo.SaveJoinerAsEx( args(1), 1 )
or
result = VideoReDo.SaveJoinerAsEx( args(1), 1 )

I think I remember seeing in another thread that the COM routines use the version that was last launched interactively.
msmart is correct. If you're running multiple versions of VRD+ and/or TVS on your system, the last one launched interactively will be the one used by our COM routines.
 

pwantzel

New member
I tried
call VideoReDo.SaveJoinerAsEx( args(1), 1 )
and that worked fine. Thank you.

May I suggest that you fix the example script that is included on your COM routine help page, which I used as a base for my script and which has the wrong syntax for this statement.

So far as the VideoReDo version is concerned, I have been using version 547 exclusively for a while, but the COM call still returned version 507, which I haven't used for some time. Although 507 is still installed on my computer. This happened many times while I was working on this yesterday. During which I ran my script and ran VRD 547 interactively many times.

However, for some strange reason, when I tried it this morning, with the fix above, it returned version 547! Any idea what's going on?
 
Top Bottom