Can't get MPEG-PS files to open.

I have for some time now being cutting out the adds from TV shows either recorded off my PVR or from my PC's tuner cards. I then run them through Handbrake to make the file size smaller.

Now Handbrake can't open them, while other players can play them. I have tried this in both the .95 & new 9.6 versions of Handbrake.

I seem to recall that older files created this way were MPEG2. Now the MediaInfo tool says that the files are MPEG-PS. I see that others on this forum can edit these files so I'm presuming that the problem is elsewhere. Any Ideas?
 

Dan203

Senior Developer
Staff member
I don't quite understand. Are you having trouble opening the original files in VideoReDo? Or are you having trouble opening the edited files in Handbrake?

Dan
 

Dan203

Senior Developer
Staff member
Nothing has changed in the PS muxer in quite some time so it's unlikely this is a problem with VideoReDo unless you changed one of the settings.

Are the original files .mpg files as well? If so will Handbrake open them before they are edited?

Dan
 
The original file & the DRD file according to MediaInfo tool are both MPEG-PS.

I have just gone to the PC tuner card & asked it to record a program. It opens in HandBrake OK. I then trim the file & Handbrake can't open it. You may be correct when you say that some setting has been changed but I have no idea what one. Any ideas?
 

Dan203

Senior Developer
Staff member
I don't know which one might have changed, but if you do a complete uninstall and reinstall it will clear all of your settings and reset them to defaults.

Dan
 
This is truly bizarre. I did what you suggested & downloaded & installed version 3.20.2.629. Previously I had version 3.20.2.609b. I select the same file & get this message, the same one I had before.

'No Title(s) found. Your Source may be copy protected, badly mastered or in a format that Handbrake does not support.'

The problem can't be copy protection because your program would not have trimmed it in the first place. It must be a format that Handbrake supports because it played before I trimmed it. I'm puzzled!
 

Dan203

Senior Developer
Staff member
That is bizarre. I tried editing and saving several .mpg files and they all opened in Handbrake just fine. Maybe you should try uninstalling and reinstalling handbrake. Maybe something is corrupt in it's configuration?

If that doesn't work edit a small chunk out of one of the files, a minute or two, try it in Handbrake to make sure you still get the error and if you do upload it to our FTP...

http://www.videoredo.net/msgBoard/showthread.php?t=15807

I'll try it in Handbrake on my machine and that will tell us if it's the file or your system causing the problem.

Dan
 
Top Bottom