634d random COM output problem

#1
When I process MPEG-2 in a transport stream (audio is not recoded) with my simple com script occasionally VRD leaves the Output dialogue box open after it has signalled my script (script checks IsOutputInProgress every 100 ms) that it has completed output. When this happens the pause / abort buttons do nothing. The only way to continue is to quit the com script (and let it clean up the instance of VRD itself) or kill VRD via task manager.
 

Danr

Administrator
Staff member
#2
Can I assume you're not running in Silent mode?

Can you email us your script to support?
 
Last edited:

Danr

Administrator
Staff member
#4
Trying to figure out how to duplicate the problem. BTW, Try 635 just posted. We fixed a couple batch issues, not specifically what you're mentioning but you never know .....
 
#5
It's pretty random so it might take a while before it happens again. VRD 3.x used to occasionally leave the output dialogue open but the main window would return allowing it to still be used / closed normally.
 

Dan203

Senior Developer
Staff member
#11
I think I know what's causing this. However it's a timing/threading issue, so it's difficult to duplicate. I'm going to make a change for the next release that I think will fix it, but we wont really know for sure until you give it a try.

Dan
 
#12
638f shows the problem. In case my script is provoking the problem I changed the COM check interval to 250ms but it doesn't seem to have helped.
 
Last edited:

Dan203

Senior Developer
Staff member
#13
Yeah we're still having trouble with the output complete dialog and COM. It's effecting the batch manager too. It's on my list of things to look into.

Dan
 
Top