634d output stalls with PCM audio

DrP

Member
When outputting edits from an AVC transport stream source file to elementary streams and converting the audio to PCM (using the default h264 elementary profile but changing audio to PCM) 634d stalls on the second scene with the yellow exclamation mark. VRD stays stalled until the process is manually cancelled. The output files eventually cease to grow in this state, the size increase slows right down, then stops. Once cancelled the output files remain locked by VRD. VRD does not consume any significant amount of CPU time when it has reached the stalled state.

Outputting without recoding the audio, or even recoding it to another compressed format (MP2 256k and AAC 128k tried) does not stall.

The problem can be reproduced when the source is the QSF of the original file too.
 
Last edited:

Dan203

Senior Developer
Staff member
Does it lock up if you output the file without editing it? Or only when you edit and recode the audio?

Dan
 

DrP

Member
Selecting the whole file and outputting with the same profile and converting audio to PCM does not stall.
 

Dan203

Senior Developer
Staff member
Are you doing anything else with the audio? Adjusting the volume? Using any of the equalization features?

Dan
 

DrP

Member
No, just changing to PCM. All I do is change the encoding type to LPCM/WAV. Sample rate = no change, compression = none, normalisation = none, allow multiple audio streams is ticked.
 

DrP

Member
A single MPEG L2 audio only. FWIW the QSF log shows the source file has no problems apart from cleaning up the audio & video at the end of the file.
 
Last edited:

DrP

Member
I've noticed some more behaviour that may be related to this and may point you in the right direction.

I have written a simple com script that outputs the selections in an editing session to separate elementary stream files. The script reads the list of cut points, clears VRs cut list then sets each section in turn and outputs it using the filesaveprofile method.

If the profile is set to output the audio as is or recompressed the video cuts are output correctly.

If the profile is set to output the audio as PCM the video is not necessarily output correctly. If the start of the cut is on an I frame the video is output correctly but if the start is not on an I frame the video is output starting on the closest previous I frame. I thought this may be related to the Force IFrame seek (secs) option in the VRD options but setting this to 0 makes no difference to this problem.

Regardless of which audio output format is selected when my com script adds each selection before outputting it the selection starts on the correct frame in VRD's GUI (picture shown is correct, cut starts at the correct time).
 
Last edited:
Top Bottom